Resolved
Services are operating normally and notes in progress were backfilled.
Monitoring
Mitigations have been applied and performance is improving. We are monitoring system behavior to confirm full recovery.
Identified
We have identified the issue and implemented a fix. We are monitoring the increased latency and expect to see it return to normal soon.