Automated writebacks to HCHB via the Referrals product were failing due to Citrix session and authentication errors on the HCHB side. Customers were able to complete writebacks manually as a workaround, but this caused delays.
After coordination with Compassus and escalation to HCHB Tier 2 support, no further internal action was identified. The issue is confirmed to be external, and ongoing monitoring did not reveal additional errors on our side.
Resolved
Automated writebacks to HCHB via the Referrals product were failing due to Citrix session and authentication errors on the HCHB side. Customers were able to complete writebacks manually as a workaround, but this caused delays.
After coordination with Compassus and escalation to HCHB Tier 2 support, no further internal action was identified. The issue is confirmed to be external, and ongoing monitoring did not reveal additional errors on our side.
Monitoring
Automated writebacks to HCHB are still failing, requiring manual intervention and causing delays for customers using Referrals.
Initial findings indicate the issue is related to Citrix session failures and authentication errors on the HCHB side. This issue has escalated to HCHB Tier 2 support to gather further log data and investigate.
We are coordinating closely with Compassus and will keep the incident open while we await further updates from their investigation.
Monitoring
Latest Update: We are currently addressing intermittent failures with the HCHB writeback process. Our logs indicate that while some jobs complete successfully, others encounter connectivity errors or session timeouts during the login phase.
Current Impact: Users may experience inconsistent automated writeback performance. We have confirmed our infrastructure is reaching the gateway successfully, but the connection within the HCHB environment remains unstable. We are working to stabilize these sessions and will provide another update as soon as we have more information.
Investigating
Current Status: Our team is investigating a technical issue where automated writebacks to HCHB are intermittently failing. During scheduled jobs, the HCHB system is becoming unresponsive, causing processes to timeout.
User Impact: Automated workflows are interrupted. While manual writebacks remain functional for most charts.
Next Steps: Engineering is currently investigating this incident.