Resolved
The service disruption issue has been confirmed to be fully resolved, and all impacted services are functioning normally.
Monitoring
Mitigations have been applied and performance is improving. We are monitoring system behavior to confirm full recovery.
Investigating
We are investigating reports of degraded performance affecting portions of the platform. Our teams are analyzing metrics to determine the scope and cause.