Resolved
The performance issue has been resolved, and all services are operating normally.
Monitoring
Mitigations have been applied and performance is improving. We are monitoring system behavior to confirm full recovery. We will send out the support bulletin shortly for more details.
Investigating
We are investigating reports of degraded performance affecting portions of the platform. Our teams are analyzing metrics to determine the scope and cause.