Resolved
The note generation slowness has been fully resolved, and all impacted services are functioning normally.
Identified
We have identified the a issue with note generation and are working to remediate it. Some users may see slower than expected note generation times.