Resolved
The service disruption issue has been fully resolved, and all impacted services are functioning normally.
Monitoring
Core functionality has been restored and we are monitoring systems to ensure stability.
Identified
New scribes should be completed as expected. Some scribes recorded 20+ minutes ago may still be in progress.
Identified
We have confirmed one of our third-party service providers is experiencing an outage, causing disruptions to our platform. We are working with the service provider to obtain resolution timelines and minimize impact.