Commure

Web platform service disruption
Resolved·Full outage

We've resolved the issue and services are operating normally.

Thu, Nov 20, 2025, 10:43 PM
(2 weeks ago)
·
Affected components
Updates

Resolved

We've resolved the issue and services are operating normally.

Thu, Nov 20, 2025, 10:43 PM

Investigating

We are investigating a service disruption affecting our web platform. Please switch to the Commure Ambient mobile app or utilize the Chrome extension to continue accessing your workflows during this temporary disruption.

Thu, Nov 20, 2025, 10:19 PM(24 minutes earlier)