Commure

Intermittent access issues affecting certain Commure websites
Resolved·Full outage

We've resolved the issue and services are operating normally.

Tue, Nov 18, 2025, 03:25 PM
(2 weeks ago)
·
Affected components
Updates

Resolved

We've resolved the issue and services are operating normally.

Tue, Nov 18, 2025, 03:25 PM

Monitoring

Cloudflare services have been restored and we are monitoring to ensure all services are operating normally.

Tue, Nov 18, 2025, 02:46 PM(39 minutes earlier)

Monitoring

We're continuing to monitor impact from an ongoing incident with Cloudflare, who have updated their status page here. All mobile platforms, and the Chrome Extension are functioning as expected.

Tue, Nov 18, 2025, 02:41 PM

Identified

We have confirmed that the incident is caused by an issue with one of our third-party service, Cloudflare. We will provide updates as they become available.

Tue, Nov 18, 2025, 02:11 PM(30 minutes earlier)